aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-29 17:54:16 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-31 16:51:46 +0200
commitc7634180fc8104e2f770f2efbe77b5235514fd75 (patch)
tree28a18c68ae756496f132658b94d9445393738e4d /target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch
parent1d45ed1477571d0dd3d7d39dd9b45d2a05c57a0a (diff)
downloadupstream-c7634180fc8104e2f770f2efbe77b5235514fd75.tar.gz
upstream-c7634180fc8104e2f770f2efbe77b5235514fd75.tar.bz2
upstream-c7634180fc8104e2f770f2efbe77b5235514fd75.zip
kernel: bump 4.19 to 4.19.62
Refreshed all patches. Remove upstreamed: - 023-0013-crypto-crypto4xx-fix-AES-CTR-blocksize-value.patch - 023-0014-crypto-crypto4xx-fix-blocksize-for-cfb-and-ofb.patch - 023-0015-crypto-crypto4xx-block-ciphers-should-only-accept-co.patch - 950-0252-staging-bcm2835_camera-Ensure-all-buffers-are-return.patch - 950-0253-staging-bcm2835-camera-Remove-check-of-the-number-of.patch - 950-0254-staging-bcm2835-camera-Handle-empty-EOS-buffers-whil.patch - 950-0489-staging-mmal-vchiq-Replace-spinlock-protecting-conte.patch - 0021-ARM-dts-gemini-Fix-up-DNS-313-compatible-string.patch - 049-v4.20-mips-remove-superfluous-check-for-linux.patch - 100-MIPS-fix-build-on-non-linux-hosts.patch - 303-MIPS-Fix-bounds-check-virt_addr_valid.patch - 0002-usb-dwc2-use-a-longer-AHB-idle-timeout-in-dwc2_core_.patch Altered patches: - 950-0267-staging-vc04_services-Split-vchiq-mmal-into-a-module.patch - 700-net-add-qualcomm-mdio-and-phy.patch Fixes: - CVE-2019-3846 New symbol: - AX88796B_PHY Compile-tested on: cns3xxx, imx6 Runtime-tested on: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch')
-rw-r--r--target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch b/target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch
deleted file mode 100644
index 5d34df4283..0000000000
--- a/target/linux/generic/pending-4.19/100-MIPS-fix-build-on-non-linux-hosts.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 4ee213d8c2afeab9a68f8530317260298b4b6b82 Mon Sep 17 00:00:00 2001
-From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
-Date: Wed, 19 Jun 2019 08:16:33 +0100
-Subject: [PATCH] MIPS: fix build on non-linux hosts
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-calc_vmlinuz_load_addr.c requires SZ_64K to be defined for alignment
-purposes. It included "../../../../include/linux/sizes.h" to define
-that size, however "sizes.h" tries to include <linux/const.h> which
-assumes linux system headers. These may not exist eg. the following
-error was encountered when building Linux for OpenWrt under macOS:
-
-In file included from arch/mips/boot/compressed/calc_vmlinuz_load_addr.c:16:
-arch/mips/boot/compressed/../../../../include/linux/sizes.h:11:10: fatal error: 'linux/const.h' file not found
- ^~~~~~~~~~
-
-Change makefile to force building on local linux headers instead of
-system headers. Also change eye-watering relative reference in include
-file spec.
-
-Thanks to Jo-Philip Wich & Petr Štetiar for assistance in tracking this
-down & fixing.
-
-Suggested-by: Jo-Philipp Wich <jo@mein.io>
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
-Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
----
- arch/mips/boot/compressed/Makefile | 2 ++
- arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
---- a/arch/mips/boot/compressed/Makefile
-+++ b/arch/mips/boot/compressed/Makefile
-@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.i
- $(obj)/piggy.o: $(obj)/dummy.o $(obj)/vmlinux.bin.z FORCE
- $(call if_changed,objcopy)
-
-+HOSTCFLAGS_calc_vmlinuz_load_addr.o += $(LINUXINCLUDE)
-+
- # Calculate the load address of the compressed kernel image
- hostprogs-y := calc_vmlinuz_load_addr
-
---- a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
-+++ b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
-@@ -13,7 +13,7 @@
- #include <stdint.h>
- #include <stdio.h>
- #include <stdlib.h>
--#include "../../../../include/linux/sizes.h"
-+#include <linux/sizes.h>
-
- int main(int argc, char *argv[])
- {