aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-3.18/904-debloat_dma_buf.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:29:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 22:41:38 +0200
commit1325e74e0c2f9ebdafe05b1492cec77a60059920 (patch)
treeaf21c4890a4ae5c08dc08ee7cabdc14a651f33ad /target/linux/generic/pending-3.18/904-debloat_dma_buf.patch
parent675832de79ec14ddc1183a66d1084aff7a856289 (diff)
downloadupstream-1325e74e0c2f9ebdafe05b1492cec77a60059920.tar.gz
upstream-1325e74e0c2f9ebdafe05b1492cec77a60059920.tar.bz2
upstream-1325e74e0c2f9ebdafe05b1492cec77a60059920.zip
kernel: Remove support for kernel 3.18
No target is using kernel 3.18 anymore, remove all the generic support for kernel 3.18. The removed packages are depending on kernel 3.18 only and are not used on any recent kernel. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/generic/pending-3.18/904-debloat_dma_buf.patch')
-rw-r--r--target/linux/generic/pending-3.18/904-debloat_dma_buf.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/generic/pending-3.18/904-debloat_dma_buf.patch b/target/linux/generic/pending-3.18/904-debloat_dma_buf.patch
deleted file mode 100644
index a5e0be2496..0000000000
--- a/target/linux/generic/pending-3.18/904-debloat_dma_buf.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/base/Kconfig
-+++ b/drivers/base/Kconfig
-@@ -229,7 +229,7 @@ config SOC_BUS
- source "drivers/base/regmap/Kconfig"
-
- config DMA_SHARED_BUFFER
-- bool
-+ tristate
- default n
- select ANON_INODES
- help
---- a/drivers/dma-buf/Makefile
-+++ b/drivers/dma-buf/Makefile
-@@ -1 +1,2 @@
--obj-y := dma-buf.o fence.o reservation.o seqno-fence.o
-+obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
-+dma-shared-buffer-objs := dma-buf.o fence.o reservation.o seqno-fence.o
---- a/drivers/dma-buf/dma-buf.c
-+++ b/drivers/dma-buf/dma-buf.c
-@@ -32,6 +32,7 @@
- #include <linux/seq_file.h>
- #include <linux/poll.h>
- #include <linux/reservation.h>
-+#include <linux/module.h>
-
- static inline int is_dma_buf_file(struct file *);
-
-@@ -904,4 +905,5 @@ static void __exit dma_buf_deinit(void)
- {
- dma_buf_uninit_debugfs();
- }
--__exitcall(dma_buf_deinit);
-+module_exit(dma_buf_deinit);
-+MODULE_LICENSE("GPL");
---- a/kernel/sched/core.c
-+++ b/kernel/sched/core.c
-@@ -1823,6 +1823,7 @@ int wake_up_state(struct task_struct *p,
- {
- return try_to_wake_up(p, state, 0);
- }
-+EXPORT_SYMBOL_GPL(wake_up_state);
-
- /*
- * This function clears the sched_dl_entity static params.