aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.9/201-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-27 14:32:10 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-04 20:28:14 +0100
commitf791fb4af45032a653ba7c850f4564923871cb16 (patch)
treec1fc4e564c8e27faad582e5b55a9ce91816a241c /target/linux/generic/patches-4.9/201-extra_optimization.patch
parent7d00cfe9bb693e376ac9d035e13f8ce8a5ff572c (diff)
downloadupstream-f791fb4af45032a653ba7c850f4564923871cb16.tar.gz
upstream-f791fb4af45032a653ba7c850f4564923871cb16.tar.bz2
upstream-f791fb4af45032a653ba7c850f4564923871cb16.zip
kernel: add linux 4.9 support
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixes]
Diffstat (limited to 'target/linux/generic/patches-4.9/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.9/201-extra_optimization.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.9/201-extra_optimization.patch b/target/linux/generic/patches-4.9/201-extra_optimization.patch
new file mode 100644
index 0000000000..7e67017ec3
--- /dev/null
+++ b/target/linux/generic/patches-4.9/201-extra_optimization.patch
@@ -0,0 +1,18 @@
+--- a/Makefile
++++ b/Makefile
+@@ -636,12 +636,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
+ endif
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
+ else
+ ifdef CONFIG_PROFILE_ALL_BRANCHES
+-KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+ endif
+