aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
commit621677154f39f2e0b698a558b8b795db84a8e014 (patch)
tree3c4d60241f9ad7f52f12aa022af8b5a684b2ab08 /target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
parent4454a3fb6375cf1adf17f63a54cd7660bc40caa7 (diff)
downloadupstream-621677154f39f2e0b698a558b8b795db84a8e014.tar.gz
upstream-621677154f39f2e0b698a558b8b795db84a8e014.tar.bz2
upstream-621677154f39f2e0b698a558b8b795db84a8e014.zip
kernel: add linux 4.4 support
Based on 4.4-rc3. Runtime tested on MIPS. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47701
Diffstat (limited to 'target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..8b0cc2b7b0
--- /dev/null
+++ b/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1654,3 +1654,6 @@ source crypto/asymmetric_keys/Kconfig
+ source certs/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -123,6 +123,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #