aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/721-phy_packets.patch
diff options
context:
space:
mode:
authorStijn Segers <francesco.borromini@inventati.org>2016-09-30 08:34:01 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-09-30 13:34:04 +0200
commit949cfbb24374be151e2c01db09dd98bc8537a989 (patch)
tree8a87fc4295daec2beee33827e85592f2b932a791 /target/linux/generic/patches-4.4/721-phy_packets.patch
parentfc88eb3fdfce6d39b4c62158cf6f42605a360a1e (diff)
downloadupstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.gz
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.bz2
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.zip
kernel: update kernel 4.4 to version 4.4.22
Forgot to update kernel-version.mk, so updated patch. Compile-tested on x86/64 and ar71xx; run-tested on x86/64 and ar71xx. Signed-off-by: Stijn Segers <francesco.borromini@inventati.org>
Diffstat (limited to 'target/linux/generic/patches-4.4/721-phy_packets.patch')
-rw-r--r--target/linux/generic/patches-4.4/721-phy_packets.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/patches-4.4/721-phy_packets.patch b/target/linux/generic/patches-4.4/721-phy_packets.patch
index c3fbb955b8..7f288f884c 100644
--- a/target/linux/generic/patches-4.4/721-phy_packets.patch
+++ b/target/linux/generic/patches-4.4/721-phy_packets.patch
@@ -1,6 +1,6 @@
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -1298,6 +1298,7 @@ enum netdev_priv_flags {
+@@ -1297,6 +1297,7 @@ enum netdev_priv_flags {
IFF_NO_QUEUE = 1<<21,
IFF_OPENVSWITCH = 1<<22,
IFF_L3MDEV_SLAVE = 1<<23,
@@ -8,7 +8,7 @@
};
#define IFF_802_1Q_VLAN IFF_802_1Q_VLAN
-@@ -1324,6 +1325,7 @@ enum netdev_priv_flags {
+@@ -1323,6 +1324,7 @@ enum netdev_priv_flags {
#define IFF_NO_QUEUE IFF_NO_QUEUE
#define IFF_OPENVSWITCH IFF_OPENVSWITCH
#define IFF_L3MDEV_SLAVE IFF_L3MDEV_SLAVE
@@ -16,7 +16,7 @@
/**
* struct net_device - The DEVICE structure.
-@@ -1603,6 +1605,11 @@ struct net_device {
+@@ -1602,6 +1604,11 @@ struct net_device {
const struct l3mdev_ops *l3mdev_ops;
#endif
@@ -28,7 +28,7 @@
const struct header_ops *header_ops;
unsigned int flags;
-@@ -1669,6 +1676,10 @@ struct net_device {
+@@ -1668,6 +1675,10 @@ struct net_device {
struct mpls_dev __rcu *mpls_ptr;
#endif