aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/201-extra_optimization.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-17 14:30:40 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-18 15:14:39 +0100
commit65044a50ab687274bcec79eb85ac7854f134129f (patch)
tree444e1ff3bba95d5f152038d0b054a7fb01cfe9e0 /target/linux/generic/patches-4.4/201-extra_optimization.patch
parent26b80696041beb28deea2efe18e66a8a2a91e650 (diff)
downloadupstream-65044a50ab687274bcec79eb85ac7854f134129f.tar.gz
upstream-65044a50ab687274bcec79eb85ac7854f134129f.tar.bz2
upstream-65044a50ab687274bcec79eb85ac7854f134129f.zip
kernel: bump 4.4 to 4.4.167
Refreshed all patches. Removed upstreamed: - 203-MIPS-ath79-fix-restart.patch - 330-Revert-MIPS-BCM47XX-Enable-74K-Core-ExternalSync-for.patch - 051-0001-ovl-rename-is_merge-to-is_lowest.patch - 051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch - 051-0005-ovl-proper-cleanup-of-workdir.patch Altered patches: - 201-extra_optimization.patch - 304-mips_disable_fpu.patch Compile-tested on: ar71xx, cns3xxx, imx6, mpc85xx Runtime-tested on: ar71xx, cns3xxx, imx6, mpc85xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/generic/patches-4.4/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.4/201-extra_optimization.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/patches-4.4/201-extra_optimization.patch b/target/linux/generic/patches-4.4/201-extra_optimization.patch
index f5f542e062..d9d24263f7 100644
--- a/target/linux/generic/patches-4.4/201-extra_optimization.patch
+++ b/target/linux/generic/patches-4.4/201-extra_optimization.patch
@@ -1,11 +1,11 @@
--- a/Makefile
+++ b/Makefile
-@@ -628,12 +628,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -639,12 +639,12 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
+-KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
++KBUILD_CFLAGS += $(call cc-option,-Oz,-Os) $(EXTRA_OPTIMIZATION)
else
ifdef CONFIG_PROFILE_ALL_BRANCHES
-KBUILD_CFLAGS += -O2