aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
diff options
context:
space:
mode:
authorStijn Segers <francesco.borromini@inventati.org>2016-09-30 08:34:01 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-09-30 13:34:04 +0200
commit949cfbb24374be151e2c01db09dd98bc8537a989 (patch)
tree8a87fc4295daec2beee33827e85592f2b932a791 /target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
parentfc88eb3fdfce6d39b4c62158cf6f42605a360a1e (diff)
downloadupstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.gz
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.bz2
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.zip
kernel: update kernel 4.4 to version 4.4.22
Forgot to update kernel-version.mk, so updated patch. Compile-tested on x86/64 and ar71xx; run-tested on x86/64 and ar71xx. Signed-off-by: Stijn Segers <francesco.borromini@inventati.org>
Diffstat (limited to 'target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch')
-rw-r--r--target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch17
1 files changed, 9 insertions, 8 deletions
diff --git a/target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch b/target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
index 9abb923932..dd75ef4f47 100644
--- a/target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
+++ b/target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
@@ -292,30 +292,31 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
- err = ubifs_add_dirt(c, lnum, dlen2);
- if (err)
- goto out_ro;
+-
+- dent_key_init(c, &key, old_dir->i_ino, &old_dentry->d_name);
+- err = ubifs_tnc_remove_nm(c, &key, &old_dentry->d_name);
+- if (err)
+- goto out_ro;
+ offs += aligned_dlen1;
+ if (whiteout) {
+ dent_key_init(c, &key, old_dir->i_ino, &old_dentry->d_name);
+ err = ubifs_tnc_add_nm(c, &key, lnum, offs, dlen2, &old_dentry->d_name);
+ if (err)
+ goto out_ro;
-
-- dent_key_init(c, &key, old_dir->i_ino, &old_dentry->d_name);
-- err = ubifs_tnc_remove_nm(c, &key, &old_dentry->d_name);
-- if (err)
-- goto out_ro;
++
+ ubifs_delete_orphan(c, whiteout->i_ino);
+ } else {
+ err = ubifs_add_dirt(c, lnum, dlen2);
+ if (err)
+ goto out_ro;
-
-- offs += aligned_dlen1 + aligned_dlen2;
++
+ dent_key_init(c, &key, old_dir->i_ino, &old_dentry->d_name);
+ err = ubifs_tnc_remove_nm(c, &key, &old_dentry->d_name);
+ if (err)
+ goto out_ro;
+ }
-+
+
+- offs += aligned_dlen1 + aligned_dlen2;
+ offs += aligned_dlen2;
if (new_inode) {
ino_key_init(c, &key, new_inode->i_ino);