aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-03-07 17:56:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-03-07 17:56:58 +0000
commit46c7d0d1ab610701b91ac9ba465e63f51e80ee06 (patch)
treeac61f4ccb56d99a7cf65fc19840cc4c906ce65f3 /target/linux/generic/patches-4.3/830-ledtrig_morse.patch
parent3abf5ce6564e24a388b86caf1a00f91f4262b312 (diff)
downloadupstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.tar.gz
upstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.tar.bz2
upstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.zip
kernel: remove linux 4.3 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48955
Diffstat (limited to 'target/linux/generic/patches-4.3/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-4.3/830-ledtrig_morse.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/generic/patches-4.3/830-ledtrig_morse.patch b/target/linux/generic/patches-4.3/830-ledtrig_morse.patch
deleted file mode 100644
index 87619d4a9a..0000000000
--- a/target/linux/generic/patches-4.3/830-ledtrig_morse.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -108,4 +108,8 @@ config LEDS_TRIGGER_CAMERA
- This enables direct flash/torch on/off by the driver, kernel space.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_MORSE
-+ tristate "LED Morse Trigger"
-+ depends on LEDS_TRIGGERS
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -71,3 +71,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
-
- # LED Triggers
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
-+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
---- a/drivers/leds/ledtrig-morse.c
-+++ b/drivers/leds/ledtrig-morse.c
-@@ -26,7 +26,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/leds.h>