aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-04 19:12:21 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-04 20:53:02 +0200
commit577f873dafdf3914c79ee21869288f20d419a39f (patch)
treeab095458101aea1eef8766a97dc307207464f22d /target/linux/generic/patches-4.1/830-ledtrig_morse.patch
parent9e62a7668c4085563a907da51a08819c88d04f33 (diff)
downloadupstream-577f873dafdf3914c79ee21869288f20d419a39f.tar.gz
upstream-577f873dafdf3914c79ee21869288f20d419a39f.tar.bz2
upstream-577f873dafdf3914c79ee21869288f20d419a39f.zip
kernel: remove unused morse led trigger driver
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/generic/patches-4.1/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-4.1/830-ledtrig_morse.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/generic/patches-4.1/830-ledtrig_morse.patch b/target/linux/generic/patches-4.1/830-ledtrig_morse.patch
deleted file mode 100644
index 31b578136c..0000000000
--- a/target/linux/generic/patches-4.1/830-ledtrig_morse.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -108,4 +108,8 @@ config LEDS_TRIGGER_CAMERA
- This enables direct flash/torch on/off by the driver, kernel space.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_MORSE
-+ tristate "LED Morse Trigger"
-+ depends on LEDS_TRIGGERS
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
-
- # LED Triggers
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
-+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
---- a/drivers/leds/ledtrig-morse.c
-+++ b/drivers/leds/ledtrig-morse.c
-@@ -26,7 +26,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/leds.h>