aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
commit1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f (patch)
tree0a83cfa5ea98e519ade4fa7f4e8a859e26bd737c /target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
parentad077832bfb03106a02b7be02b560c13e77d0436 (diff)
downloadupstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.gz
upstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.bz2
upstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.zip
generic: early (incomplete!) 4.0 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 44511
Diffstat (limited to 'target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..36776a9c47
--- /dev/null
+++ b/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1537,3 +1537,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -102,6 +102,8 @@ obj-$(CONFIG_CRYPTO_USER_API_HASH) += al
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #