aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-03-20 21:59:24 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-03-20 21:59:24 +0000
commitc9544f4af05baf5b60127ad29872488315245fb8 (patch)
tree7c5f960d67ce75a014debab8c6ab6286adffe748 /target/linux/generic/patches-3.9
parent99638c528890863b8212a4c140d9ae3cde6ecb4f (diff)
downloadupstream-c9544f4af05baf5b60127ad29872488315245fb8.tar.gz
upstream-c9544f4af05baf5b60127ad29872488315245fb8.tar.bz2
upstream-c9544f4af05baf5b60127ad29872488315245fb8.zip
kernel: add some fixes for kernel 3.9
This patch fixes some compile problems with kernel 3.9 and adds some missing linux 3.9 handling into kernel packages. SVN-Revision: 36098
Diffstat (limited to 'target/linux/generic/patches-3.9')
-rw-r--r--target/linux/generic/patches-3.9/259-regmap_dynamic.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/259-regmap_dynamic.patch b/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
index 3479d1a0a8..480f2c181f 100644
--- a/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.9/259-regmap_dynamic.patch
@@ -39,6 +39,20 @@
enum regmap_endian {
/* Unspecified -> 0 -> Backwards compatible default */
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
+@@ -1,6 +1,8 @@
+-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++ifdef CONFIG_DEBUG_FS
++regmap-core-objs += regmap-debugfs.o
++endif
++obj-$(CONFIG_REGMAP) += regmap-core.o
+ obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
+ obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
+ obj-$(CONFIG_REGMAP_MMIO) += regmap-mmio.o
--- a/drivers/base/regmap/regmap.c
+++ b/drivers/base/regmap/regmap.c
@@ -13,6 +13,7 @@