aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitddc8718f7f4ef9723e026efac811d3338e6bcddb (patch)
tree08d6be7813310be182259388518215a17afcc18c /target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch
parent6cb1f067dc42c4bffa8862448167486333d0227e (diff)
downloadupstream-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.gz
upstream-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.bz2
upstream-ddc8718f7f4ef9723e026efac811d3338e6bcddb.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36008 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..c2e69571d8
--- /dev/null
+++ b/target/linux/generic/patches-3.9/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1291,3 +1291,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -95,6 +95,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #