aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/901-debloat_sock_diag.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-17 15:11:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-17 15:11:39 +0000
commit0a9eb9e6d79e1b734f233a7f8ecb3f1929d8acc1 (patch)
tree13e6f7873fdf64bc6039bc85ffa5a404ff519cc8 /target/linux/generic/patches-3.6/901-debloat_sock_diag.patch
parent3699160b8c9f8fd816ab2b26147993ca493b9ea7 (diff)
downloadupstream-0a9eb9e6d79e1b734f233a7f8ecb3f1929d8acc1.tar.gz
upstream-0a9eb9e6d79e1b734f233a7f8ecb3f1929d8acc1.tar.bz2
upstream-0a9eb9e6d79e1b734f233a7f8ecb3f1929d8acc1.zip
kernel: add some debloat patches, strip down procfs and make O_DIRECT support optional, saves ~15K after lzma on MIPS
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.6/901-debloat_sock_diag.patch')
-rw-r--r--target/linux/generic/patches-3.6/901-debloat_sock_diag.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/901-debloat_sock_diag.patch b/target/linux/generic/patches-3.6/901-debloat_sock_diag.patch
new file mode 100644
index 0000000000..8f161ba1a3
--- /dev/null
+++ b/target/linux/generic/patches-3.6/901-debloat_sock_diag.patch
@@ -0,0 +1,46 @@
+--- a/net/Kconfig
++++ b/net/Kconfig
+@@ -85,6 +85,9 @@ source "net/netlabel/Kconfig"
+
+ endif # if INET
+
++config SOCK_DIAG
++ bool
++
+ config NETWORK_SECMARK
+ bool "Security Marking"
+ help
+--- a/net/core/Makefile
++++ b/net/core/Makefile
+@@ -8,9 +8,9 @@ obj-y := sock.o request_sock.o skbuff.o
+ obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
+
+ obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
+- neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
+- sock_diag.o
++ neighbour.o rtnetlink.o utils.o link_watch.o filter.o
+
++obj-$(CONFIG_SOCK_DIAG) += sock_diag.o
+ obj-$(CONFIG_XFRM) += flow.o
+ obj-y += net-sysfs.o
+ obj-$(CONFIG_NET_PKTGEN) += pktgen.o
+--- a/net/ipv4/Kconfig
++++ b/net/ipv4/Kconfig
+@@ -404,6 +404,7 @@ config INET_LRO
+
+ config INET_DIAG
+ tristate "INET: socket monitoring interface"
++ select SOCK_DIAG
+ default y
+ ---help---
+ Support for INET (TCP, DCCP, etc) socket monitoring interface used by
+--- a/net/unix/Kconfig
++++ b/net/unix/Kconfig
+@@ -22,6 +22,7 @@ config UNIX
+ config UNIX_DIAG
+ tristate "UNIX: socket monitoring interface"
+ depends on UNIX
++ select SOCK_DIAG
+ default n
+ ---help---
+ Support for UNIX socket monitoring interface used by the ss tool.