aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/725-phy_rtl8306.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
commit648f1d01710c2e9d5bb3e296d9553120e5bbe51e (patch)
tree413eb23081ae9b34b54a6ee479e5a2bf0085877d /target/linux/generic/patches-3.6/725-phy_rtl8306.patch
parent35c7b0ba8a06d128adf45ca58377299e988d4e84 (diff)
downloadupstream-648f1d01710c2e9d5bb3e296d9553120e5bbe51e.tar.gz
upstream-648f1d01710c2e9d5bb3e296d9553120e5bbe51e.tar.bz2
upstream-648f1d01710c2e9d5bb3e296d9553120e5bbe51e.zip
[generic]: linux 3.6 support (work in progress)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33897 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.6/725-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-3.6/725-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/725-phy_rtl8306.patch b/target/linux/generic/patches-3.6/725-phy_rtl8306.patch
new file mode 100644
index 0000000000..db0ee6582e
--- /dev/null
+++ b/target/linux/generic/patches-3.6/725-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -126,6 +126,10 @@ config AR8216_PHY
+ select ETHERNET_PACKET_MANGLE
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o