aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/201-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
commit949b46d13d1e21b596f505a2e69956565e365d77 (patch)
tree4b51f4852224df7cc2d056071ee51bfcb9c5b7f4 /target/linux/generic/patches-3.6/201-extra_optimization.patch
parent0d2cf5f9e363c8e41b32921b0ab2aa3d4621dfd5 (diff)
downloadupstream-949b46d13d1e21b596f505a2e69956565e365d77.tar.gz
upstream-949b46d13d1e21b596f505a2e69956565e365d77.tar.bz2
upstream-949b46d13d1e21b596f505a2e69956565e365d77.zip
linux 3.6 support (work in progress)
SVN-Revision: 33897
Diffstat (limited to 'target/linux/generic/patches-3.6/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.6/201-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/201-extra_optimization.patch b/target/linux/generic/patches-3.6/201-extra_optimization.patch
new file mode 100644
index 0000000000..6fe8b0938d
--- /dev/null
+++ b/target/linux/generic/patches-3.6/201-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -559,9 +559,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -620,6 +620,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+