aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-19 19:44:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-19 19:44:15 +0000
commit895c5b36f3ea13ae4982dcf3f1fc6694dcd19f60 (patch)
tree9e49ec050a15daf69e163d570cd8b92c9388d19c /target/linux/generic/patches-3.3
parent51f454db111043e588b016a80c5f73c270b57ba9 (diff)
downloadupstream-895c5b36f3ea13ae4982dcf3f1fc6694dcd19f60.tar.gz
upstream-895c5b36f3ea13ae4982dcf3f1fc6694dcd19f60.tar.bz2
upstream-895c5b36f3ea13ae4982dcf3f1fc6694dcd19f60.zip
AA: generic: add driver for the the RTL8367R{B,-VB} switches
Backport of r33839. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33868 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3')
-rw-r--r--target/linux/generic/patches-3.3/729-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
new file mode 100644
index 0000000000..82a7386f96
--- /dev/null
+++ b/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -199,6 +199,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o