aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/700-swconfig.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
committerJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
commitafbffe9fcd7261cfcf8ff462ad81aea553b2241a (patch)
tree520b2ce27d8ce9fca04ceff102605b733c4e27d2 /target/linux/generic/patches-3.3/700-swconfig.patch
parent47f5be9659a16031b9ce946b437b5af71cc004a8 (diff)
downloadupstream-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.gz
upstream-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.bz2
upstream-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.zip
kernel: add preliminary support for linux 3.3
Based on 3.3-rc2 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29986 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-3.3/700-swconfig.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/700-swconfig.patch b/target/linux/generic/patches-3.3/700-swconfig.patch
new file mode 100644
index 0000000000..48cb64372e
--- /dev/null
+++ b/target/linux/generic/patches-3.3/700-swconfig.patch
@@ -0,0 +1,29 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,16 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
++config SWCONFIG_LEDS
++ bool "Switch LED trigger support"
++ depends on (SWCONFIG && LEDS_TRIGGERS)
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o