aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:02 +0000
commitcac0cf6daa5df1faed5bc0f7fc764506e93bace0 (patch)
treeda5a1596ae9201d3f99bb59ec8db0758aa27b03e /target/linux/generic/patches-3.3/270-regmap_dynamic.patch
parent67ad5ff2734551cf9548814b480a0bc5bacf7f1b (diff)
downloadupstream-cac0cf6daa5df1faed5bc0f7fc764506e93bace0.tar.gz
upstream-cac0cf6daa5df1faed5bc0f7fc764506e93bace0.tar.bz2
upstream-cac0cf6daa5df1faed5bc0f7fc764506e93bace0.zip
kernel: remove linux 3.3 patches and config
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44109 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3/270-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.3/270-regmap_dynamic.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch b/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
deleted file mode 100644
index b1cfc8a628..0000000000
--- a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/drivers/base/regmap/Kconfig
-+++ b/drivers/base/regmap/Kconfig
-@@ -3,16 +3,18 @@
- # subsystems should select the appropriate symbols.
-
- config REGMAP
-- default y if (REGMAP_I2C || REGMAP_SPI)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
-- bool
-+ tristate "Regmap"
-
- config REGMAP_I2C
-- tristate
-+ select REGMAP
-+ tristate "Regmap I2C"
-
- config REGMAP_SPI
-- tristate
-+ select REGMAP
-+ depends on SPI_MASTER
-+ tristate "Regmap SPI"
-
- config REGMAP_IRQ
- bool
---- a/drivers/base/regmap/Makefile
-+++ b/drivers/base/regmap/Makefile
-@@ -1,6 +1,8 @@
--obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
--obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
-+ifdef CONFIG_DEBUG_FS
-+regmap-core-objs += regmap-debugfs.o
-+endif
-+obj-$(CONFIG_REGMAP) += regmap-core.o
- obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
- obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
- obj-$(CONFIG_REGMAP_IRQ) += regmap-irq.o
---- a/drivers/base/regmap/regmap.c
-+++ b/drivers/base/regmap/regmap.c
-@@ -13,6 +13,7 @@
- #include <linux/slab.h>
- #include <linux/module.h>
- #include <linux/mutex.h>
-+#include <linux/module.h>
- #include <linux/err.h>
-
- #define CREATE_TRACE_POINTS
-@@ -679,3 +680,5 @@ static int __init regmap_initcall(void)
- return 0;
- }
- postcore_initcall(regmap_initcall);
-+
-+MODULE_LICENSE("GPL");