aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
commit4f1451b47e0483c21393b13f82d5eb24d3fb17f2 (patch)
treec3e80a16d0b4070af1ea473d644981d1df410c54 /target/linux/generic/patches-3.2/726-phy_rtl8366.patch
parent7e71e51d60fc258c9c4cb2dc07ad9c3736c59a66 (diff)
downloadupstream-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.tar.gz
upstream-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.tar.bz2
upstream-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.zip
linux/3.2: R.I.P.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.2/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-3.2/726-phy_rtl8366.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/generic/patches-3.2/726-phy_rtl8366.patch b/target/linux/generic/patches-3.2/726-phy_rtl8366.patch
deleted file mode 100644
index 49cd970fbc..0000000000
--- a/target/linux/generic/patches-3.2/726-phy_rtl8366.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -168,4 +168,29 @@ config MDIO_OCTEON
-
- If in doubt, say Y.
-
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GENERIC_GPIO
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366RB_PHY
-+ tristate "Driver for the Realtek RTL8366RB switch"
-+ select SWCONFIG
-+
-+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366 switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY || RTL8366RB_PHY
-+ depends on DEBUG_FS
-+ default n
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -22,6 +22,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o