aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/700-swconfig.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commit1bc0abb058e09fd7214507dd4a095658a4b8d122 (patch)
tree82c35f5f43253e1a2ff9c2ff1318fac1c86e57df /target/linux/generic/patches-3.2/700-swconfig.patch
parent50d4c0e31a6706f28b3c69cd24bcf0c205223e16 (diff)
downloadupstream-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.gz
upstream-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.bz2
upstream-1bc0abb058e09fd7214507dd4a095658a4b8d122.zip
kernel: add support for linux 3.2.1
SVN-Revision: 29730
Diffstat (limited to 'target/linux/generic/patches-3.2/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-3.2/700-swconfig.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/700-swconfig.patch b/target/linux/generic/patches-3.2/700-swconfig.patch
new file mode 100644
index 0000000000..48cb64372e
--- /dev/null
+++ b/target/linux/generic/patches-3.2/700-swconfig.patch
@@ -0,0 +1,29 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,16 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
++config SWCONFIG_LEDS
++ bool "Switch LED trigger support"
++ depends on (SWCONFIG && LEDS_TRIGGERS)
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o