aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/201-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
commit0b8c1c8dfbbd6a86be4b12bf4a625f44e75a461c (patch)
treed82196ea551155c8f21cfa5fef4fa565d29f4b0b /target/linux/generic/patches-3.2/201-extra_optimization.patch
parent20ba6d90e31707ee95630804a284c8bad8cc90ed (diff)
downloadupstream-0b8c1c8dfbbd6a86be4b12bf4a625f44e75a461c.tar.gz
upstream-0b8c1c8dfbbd6a86be4b12bf4a625f44e75a461c.tar.bz2
upstream-0b8c1c8dfbbd6a86be4b12bf4a625f44e75a461c.zip
linux/3.2: R.I.P.
SVN-Revision: 31905
Diffstat (limited to 'target/linux/generic/patches-3.2/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.2/201-extra_optimization.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-3.2/201-extra_optimization.patch b/target/linux/generic/patches-3.2/201-extra_optimization.patch
deleted file mode 100644
index 6fe8b0938d..0000000000
--- a/target/linux/generic/patches-3.2/201-extra_optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -559,9 +559,9 @@ endif # $(dot-config)
- all: vmlinux
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
- endif
-
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -620,6 +620,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-