aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
commitb22936646d66f2a36a70ddeb9c66a44f07b8c4ac (patch)
tree485bf7cec86903e0ab0d5cbf0daa13e36e3ab5f1 /target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch
parent90cd852f2508f82c8e02c5ee6b97ba7bf1823c55 (diff)
downloadupstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.gz
upstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.bz2
upstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.zip
drop 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch
deleted file mode 100644
index c6e9fff8c6..0000000000
--- a/target/linux/generic/patches-3.19/832-ledtrig_usbdev.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_USBDEV
-+ tristate "LED USB device Trigger"
-+ depends on USB && LEDS_TRIGGERS
-+ help
-+ This allows LEDs to be controlled by the presence/activity of
-+ an USB device. If unsure, say N.
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
- obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
-+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
---- a/drivers/leds/ledtrig-usbdev.c
-+++ b/drivers/leds/ledtrig-usbdev.c
-@@ -24,7 +24,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/slab.h>