aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/725-phy_rtl8306.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commiteac842c52b28a4fd42082f3ca8231f5874a57361 (patch)
tree514eb8ba16df65dd4b3feeb3c900279596556d09 /target/linux/generic/patches-3.19/725-phy_rtl8306.patch
parent10c00d28433d42305ead73480465ce87d047a3d2 (diff)
downloadupstream-eac842c52b28a4fd42082f3ca8231f5874a57361.tar.gz
upstream-eac842c52b28a4fd42082f3ca8231f5874a57361.tar.bz2
upstream-eac842c52b28a4fd42082f3ca8231f5874a57361.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44126 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.19/725-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-3.19/725-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/725-phy_rtl8306.patch b/target/linux/generic/patches-3.19/725-phy_rtl8306.patch
new file mode 100644
index 0000000000..af6083bc74
--- /dev/null
+++ b/target/linux/generic/patches-3.19/725-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -152,6 +152,10 @@ config AR8216_PHY
+ select ETHERNET_PACKET_MANGLE
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -23,6 +23,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o