aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/201-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
commitb22936646d66f2a36a70ddeb9c66a44f07b8c4ac (patch)
tree485bf7cec86903e0ab0d5cbf0daa13e36e3ab5f1 /target/linux/generic/patches-3.19/201-extra_optimization.patch
parent90cd852f2508f82c8e02c5ee6b97ba7bf1823c55 (diff)
downloadupstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.gz
upstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.bz2
upstream-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.zip
drop 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.19/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.19/201-extra_optimization.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/target/linux/generic/patches-3.19/201-extra_optimization.patch b/target/linux/generic/patches-3.19/201-extra_optimization.patch
deleted file mode 100644
index a3398267d6..0000000000
--- a/target/linux/generic/patches-3.19/201-extra_optimization.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -614,9 +614,9 @@ include $(srctree)/arch/$(SRCARCH)/Makef
- KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
-+KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
- endif
-
- # Tell gcc to never replace conditional load with a non-conditional one