aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-04-11 10:28:14 +0000
committerLuka Perkov <luka@openwrt.org>2015-04-11 10:28:14 +0000
commit4398ecd73dcf8554c0e495de082e4677440c1d5c (patch)
treee24faee648bd7fe02dcdb4a9f916f88324797735 /target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
parentadb7aa14be1321e4ee57b2564edeb558d7eedcda (diff)
downloadupstream-4398ecd73dcf8554c0e495de082e4677440c1d5c.tar.gz
upstream-4398ecd73dcf8554c0e495de082e4677440c1d5c.tar.bz2
upstream-4398ecd73dcf8554c0e495de082e4677440c1d5c.zip
generic: drop 3.14
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45375 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
deleted file mode 100644
index c0568eb8d1..0000000000
--- a/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_USBDEV
-+ tristate "LED USB device Trigger"
-+ depends on USB && LEDS_TRIGGERS
-+ help
-+ This allows LEDs to be controlled by the presence/activity of
-+ an USB device. If unsure, say N.
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -62,3 +62,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
- obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
-+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
---- a/drivers/leds/ledtrig-usbdev.c
-+++ b/drivers/leds/ledtrig-usbdev.c
-@@ -24,7 +24,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/slab.h>