aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit2b43bb49dec4546cdca7e627b06e7682ae742591 (patch)
tree0d58c3ccdefbe53983cda5399612b4727f0ee81d /target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch
parent3be7023c9be4e1381699ce393638ad63565c9ac5 (diff)
downloadupstream-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.gz
upstream-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.bz2
upstream-2b43bb49dec4546cdca7e627b06e7682ae742591.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch')
-rw-r--r--target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch b/target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch
new file mode 100644
index 0000000000..de6643a41e
--- /dev/null
+++ b/target/linux/generic/patches-3.14/500-yaffs-Kbuild-integration.patch
@@ -0,0 +1,18 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -39,6 +39,7 @@ source "fs/gfs2/Kconfig"
+ source "fs/ocfs2/Kconfig"
+ source "fs/btrfs/Kconfig"
+ source "fs/nilfs2/Kconfig"
++source "fs/yaffs2/Kconfig"
+
+ endif # BLOCK
+
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -126,3 +126,5 @@ obj-y += exofs/ # Multiple modules
+ obj-$(CONFIG_CEPH_FS) += ceph/
+ obj-$(CONFIG_PSTORE) += pstore/
+ obj-$(CONFIG_EFIVAR_FS) += efivarfs/
++obj-$(CONFIG_YAFFS_FS) += yaffs2/
++