aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-08-25 16:30:44 +0000
committerJohn Crispin <john@openwrt.org>2014-08-25 16:30:44 +0000
commitc9813699b63c8df6d1b08d51b772cebee537d8cc (patch)
tree2cf5ae912de6a53ae02d4c9bcc5bb8f0b1775bb5 /target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
parent730589281ee8940016bacf856d566e7ceab719af (diff)
downloadupstream-c9813699b63c8df6d1b08d51b772cebee537d8cc.tar.gz
upstream-c9813699b63c8df6d1b08d51b772cebee537d8cc.tar.bz2
upstream-c9813699b63c8df6d1b08d51b772cebee537d8cc.zip
kernel: add own Kconfig for OpenWrt mtdsplit drivers
There are pretty many OpenWrt patches against mtd subsystem resulting in a bit of mess and growing maintenance cost. My idea is to use an extra "mtdsplit" directory with OpenWrt specific files (including Kconfig). This is the first step to achieve this. This patch adds a "mtdsplit" directory with Kconfig and replaces 4 patches with a single one. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42287
Diffstat (limited to 'target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch b/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
deleted file mode 100644
index cc9a971573..0000000000
--- a/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -58,6 +58,10 @@ config MTD_SPLIT_UIMAGE_FW
- bool "uImage based firmware partition parser"
- select MTD_SPLIT
-
-+config MTD_SPLIT_LZMA_FW
-+ bool "LZMA compressed kernel based firmware partition parser"
-+ select MTD_SPLIT
-+
- config MTD_SPLIT
- def_bool n
- help
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -10,6 +10,7 @@ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
- mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
- mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
- mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
-+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
-
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o