aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/201-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit2b43bb49dec4546cdca7e627b06e7682ae742591 (patch)
tree0d58c3ccdefbe53983cda5399612b4727f0ee81d /target/linux/generic/patches-3.14/201-extra_optimization.patch
parent3be7023c9be4e1381699ce393638ad63565c9ac5 (diff)
downloadupstream-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.gz
upstream-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.bz2
upstream-2b43bb49dec4546cdca7e627b06e7682ae742591.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.14/201-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/201-extra_optimization.patch b/target/linux/generic/patches-3.14/201-extra_optimization.patch
new file mode 100644
index 0000000000..cec343cf05
--- /dev/null
+++ b/target/linux/generic/patches-3.14/201-extra_optimization.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -580,9 +580,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile