aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-24 17:14:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-24 17:14:59 +0000
commit83c85ada71d787e63531a956114f80cb160c11d8 (patch)
tree85011b8a5717c1515e2cc93c81b4b91b3edef83b /target/linux/generic/patches-3.12
parent8f3a1a27b7de2d8e6fa6bb889bc48a41990ef61e (diff)
downloadupstream-83c85ada71d787e63531a956114f80cb160c11d8.tar.gz
upstream-83c85ada71d787e63531a956114f80cb160c11d8.tar.bz2
upstream-83c85ada71d787e63531a956114f80cb160c11d8.zip
kernel/3.1x: add split code for LZMA compressed kernel based firmwares
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.12')
-rw-r--r--target/linux/generic/patches-3.12/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch23
-rw-r--r--target/linux/generic/patches-3.12/430-mtd-add-myloader-partition-parser.patch4
2 files changed, 25 insertions, 2 deletions
diff --git a/target/linux/generic/patches-3.12/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch b/target/linux/generic/patches-3.12/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
new file mode 100644
index 0000000000..cc9a971573
--- /dev/null
+++ b/target/linux/generic/patches-3.12/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -58,6 +58,10 @@ config MTD_SPLIT_UIMAGE_FW
+ bool "uImage based firmware partition parser"
+ select MTD_SPLIT
+
++config MTD_SPLIT_LZMA_FW
++ bool "LZMA compressed kernel based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -10,6 +10,7 @@ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
+ mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
++mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.12/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.12/430-mtd-add-myloader-partition-parser.patch
index 47c2fd06e7..fc352d2779 100644
--- a/target/linux/generic/patches-3.12/430-mtd-add-myloader-partition-parser.patch
+++ b/target/linux/generic/patches-3.12/430-mtd-add-myloader-partition-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -208,6 +208,22 @@ config MTD_BCM47XX_PARTS
+@@ -212,6 +212,22 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.
@@ -25,7 +25,7 @@
config MTD_BLKDEVS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o