aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/728-phy-micrel.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commitbdc2e671912c3737ec65454cc7a5ed91213f7e01 (patch)
tree4613cca2c570d5eefc520620ba3bac85f7015a4b /target/linux/generic/patches-3.12/728-phy-micrel.patch
parentbf6998b89de06eae7f3fb8cecd43482d6cb15afb (diff)
downloadupstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.gz
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.bz2
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.zip
[generic:] preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.12/728-phy-micrel.patch')
-rw-r--r--target/linux/generic/patches-3.12/728-phy-micrel.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/728-phy-micrel.patch b/target/linux/generic/patches-3.12/728-phy-micrel.patch
new file mode 100644
index 0000000000..baf5a4a7fd
--- /dev/null
+++ b/target/linux/generic/patches-3.12/728-phy-micrel.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -144,6 +144,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o