aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commitbdc2e671912c3737ec65454cc7a5ed91213f7e01 (patch)
tree4613cca2c570d5eefc520620ba3bac85f7015a4b /target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch
parentbf6998b89de06eae7f3fb8cecd43482d6cb15afb (diff)
downloadupstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.gz
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.bz2
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.zip
[generic:] preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch')
-rw-r--r--target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch b/target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch
new file mode 100644
index 0000000000..44c6b04fcf
--- /dev/null
+++ b/target/linux/generic/patches-3.12/302-mips_no_branch_likely.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also. Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y += -msoft-float
+ LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections
+ KBUILD_AFLAGS_MODULE += -mlong-calls