aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/729-phy-tantos.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commit3c5635a3aa3dd00eb47cf0191588ed64f6d10f29 (patch)
tree6b6bd393ef7dac1fdb3f9503f6bfc07e09b2ad25 /target/linux/generic/patches-3.10/729-phy-tantos.patch
parent8ef2514fb69dce5191f3e967a68663d9baa5f6d0 (diff)
downloadupstream-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.gz
upstream-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.bz2
upstream-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.10/729-phy-tantos.patch')
-rw-r--r--target/linux/generic/patches-3.10/729-phy-tantos.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/729-phy-tantos.patch b/target/linux/generic/patches-3.10/729-phy-tantos.patch
new file mode 100644
index 0000000000..13e687b70f
--- /dev/null
+++ b/target/linux/generic/patches-3.10/729-phy-tantos.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -256,3 +256,8 @@ endif # PHYLIB
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
++ select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o