aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/725-phy_rtl8306.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
commita3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741 (patch)
treeddcbfa29bdb1ce96cc700e7ed428a098053ecf8f /target/linux/generic/patches-3.0/725-phy_rtl8306.patch
parent2e55411ec7cfe7a8198b9c2a2ba771600ec882a9 (diff)
downloadupstream-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.gz
upstream-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.bz2
upstream-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.zip
linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27191 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.0/725-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-3.0/725-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.0/725-phy_rtl8306.patch b/target/linux/generic/patches-3.0/725-phy_rtl8306.patch
new file mode 100644
index 0000000000..e97b84d48c
--- /dev/null
+++ b/target/linux/generic/patches-3.0/725-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -115,6 +115,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o