aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/621-sched_act_connmark.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:50 +0000
commitd24fc7ef562a00e10414aac8576a149bfdc791a5 (patch)
treec577e15633b4bfac5436eb00dc1466751c7cd0b8 /target/linux/generic/patches-3.0/621-sched_act_connmark.patch
parentc52560302df64983422d3dd8ba7e495db9a0d792 (diff)
downloadupstream-d24fc7ef562a00e10414aac8576a149bfdc791a5.tar.gz
upstream-d24fc7ef562a00e10414aac8576a149bfdc791a5.tar.bz2
upstream-d24fc7ef562a00e10414aac8576a149bfdc791a5.zip
sched_connmark depends on NF_CONNTRACK_MARK (#8976, #9423)
SVN-Revision: 27457
Diffstat (limited to 'target/linux/generic/patches-3.0/621-sched_act_connmark.patch')
-rw-r--r--target/linux/generic/patches-3.0/621-sched_act_connmark.patch3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/generic/patches-3.0/621-sched_act_connmark.patch b/target/linux/generic/patches-3.0/621-sched_act_connmark.patch
index 9704565e7a..157421d209 100644
--- a/target/linux/generic/patches-3.0/621-sched_act_connmark.patch
+++ b/target/linux/generic/patches-3.0/621-sched_act_connmark.patch
@@ -140,7 +140,7 @@
+module_exit(connmark_cleanup_module);
--- a/net/sched/Kconfig
+++ b/net/sched/Kconfig
-@@ -602,6 +602,18 @@ config NET_ACT_CSUM
+@@ -602,6 +602,19 @@ config NET_ACT_CSUM
To compile this code as a module, choose M here: the
module will be called act_csum.
@@ -148,6 +148,7 @@
+ tristate "Connection Tracking Marking"
+ depends on NET_CLS_ACT
+ depends on NF_CONNTRACK
++ depends on NF_CONNTRACK_MARK
+ ---help---
+ Say Y here to restore the connmark from a scheduler action
+
/span> # # This is free software, licensed under the GNU General Public License v2. # See /LICENSE for more information. # # $Id: $ include $(TOPDIR)/rules.mk include $(INCLUDE_DIR)/kernel.mk PKG_NAME:=ubsec-ssb PKG_VERSION:=2009-02-21 CRYPTO_MENU:=OCF Configuration include $(INCLUDE_DIR)/package.mk define KernelPackage/ocf-ubsec-ssb SUBMENU:=$(CRYPTO_MENU) DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf TITLE:=BCM5365P IPSec Core driver FILES:=$(PKG_BUILD_DIR)/src/ubsec_ssb.$(LINUX_KMOD_SUFFIX) AUTOLOAD:=$(call AutoLoad,09,ubsec_ssb) endef define KernelPackage/ocf-ubsec-ssb/description This package contains the OCF driver for the BCM5365p IPSec Core endef define Build/Prepare mkdir -p $(PKG_BUILD_DIR) $(CP) -r ./src $(PKG_BUILD_DIR)/ endef LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2) define Build/Compile $(MAKE) -C $(LINUX_DIR) \ ARCH="$(LINUX_KARCH)" \ CROSS_COMPILE="$(TARGET_CROSS)" \ PATCHLEVEL="$(LINUX_PATCHLEVEL)" \ KERNDIR="$(LINUX_DIR)" \ SUBDIRS="$(PKG_BUILD_DIR)/src" \ modules endef $(eval $(call KernelPackage,ocf-ubsec-ssb))