aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/650-swconfig.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
commit127e4ebd32d51070fd5763e4d50aba211b02de6a (patch)
tree510a31b05cfa6ae4477fd738371cc12d3df27853 /target/linux/generic/patches-2.6.39/650-swconfig.patch
parent512bb389ee6125135c6da818686f98774191b457 (diff)
downloadupstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.gz
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.bz2
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.zip
generic: Add support for 2.6.39
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx. SVN-Revision: 26615
Diffstat (limited to 'target/linux/generic/patches-2.6.39/650-swconfig.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/650-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/650-swconfig.patch b/target/linux/generic/patches-2.6.39/650-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/650-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o