aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-18 20:10:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-18 20:10:51 +0000
commit67ea71e39723d1a2dbb505fa4402455c39716d2a (patch)
tree4f4d693fb40653de79a8107f7254d31eed9b3582 /target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch
parente738b2550a0c11172766bcdaff510ca4e9cb1d52 (diff)
downloadupstream-67ea71e39723d1a2dbb505fa4402455c39716d2a.tar.gz
upstream-67ea71e39723d1a2dbb505fa4402455c39716d2a.tar.bz2
upstream-67ea71e39723d1a2dbb505fa4402455c39716d2a.zip
linux/2.6.39: R.I.P.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31808 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch
deleted file mode 100644
index 07267eaa29..0000000000
--- a/target/linux/generic/patches-2.6.39/430-mtd_myloader_partition_parser.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -176,6 +176,22 @@ config MTD_AR7_PARTS
-
- endif # MTD_PARTITIONS
-
-+config MTD_MYLOADER_PARTS
-+ tristate "MyLoader partition parsing"
-+ depends on MTD_PARTITIONS && (ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX)
-+ ---help---
-+ MyLoader is a bootloader which allows the user to define partitions
-+ in flash devices, by putting a table in the second erase block
-+ on the device, similar to a partition table. This table gives the
-+ offsets and lengths of the user defined partitions.
-+
-+ If you need code which can detect and parse these tables, and
-+ register MTD 'partitions' corresponding to each image detected,
-+ enable this option.
-+
-+ You will still need the parsing functions to be called by the driver
-+ for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
- obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o