aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/012-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
commit127e4ebd32d51070fd5763e4d50aba211b02de6a (patch)
tree510a31b05cfa6ae4477fd738371cc12d3df27853 /target/linux/generic/patches-2.6.39/012-extra_optimization.patch
parent512bb389ee6125135c6da818686f98774191b457 (diff)
downloadupstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.gz
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.bz2
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.zip
generic: Add support for 2.6.39
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx. SVN-Revision: 26615
Diffstat (limited to 'target/linux/generic/patches-2.6.39/012-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/012-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/012-extra_optimization.patch b/target/linux/generic/patches-2.6.39/012-extra_optimization.patch
new file mode 100644
index 0000000000..8039c66523
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/012-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -543,9 +543,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -600,6 +600,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+