aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/835-gpiodev.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:30:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:30:57 +0000
commit80a4ffa1e2bc5f3ef893251babb2371c502f04ad (patch)
treee6fb6200183e257b8f8cf45857f359b053bd2a0d /target/linux/generic/patches-2.6.38/835-gpiodev.patch
parenta0559785226c7d84cf34686c0d5be8f4e15fdfe6 (diff)
downloadupstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.tar.gz
upstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.tar.bz2
upstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.zip
kernel: reorganize 2.6.38 patches, clean up block2mtd patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26690 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.38/835-gpiodev.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/835-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/835-gpiodev.patch b/target/linux/generic/patches-2.6.38/835-gpiodev.patch
new file mode 100644
index 0000000000..900358e6b0
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/835-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1047,6 +1047,14 @@ config NSC_GPIO
+ pc8736x_gpio drivers. If those drivers are built as
+ modules, this one will be too, named nsc_gpio
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -70,6 +70,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+