aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:30:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:30:57 +0000
commit80a4ffa1e2bc5f3ef893251babb2371c502f04ad (patch)
treee6fb6200183e257b8f8cf45857f359b053bd2a0d /target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch
parenta0559785226c7d84cf34686c0d5be8f4e15fdfe6 (diff)
downloadupstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.tar.gz
upstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.tar.bz2
upstream-80a4ffa1e2bc5f3ef893251babb2371c502f04ad.zip
kernel: reorganize 2.6.38 patches, clean up block2mtd patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26690 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch b/target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch
new file mode 100644
index 0000000000..fdfeb54335
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/726-phy_rtl8366.patch
@@ -0,0 +1,44 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -156,4 +156,29 @@ config MDIO_OCTEON
+
+ If in doubt, say Y.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GENERIC_GPIO
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++ bool "RTL8366 switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY || RTL8366RB_PHY
++ depends on DEBUG_FS
++ default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o