aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/670-phy_ip175c.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
commit2a7bdb2ef04b744e08d54e65e2cd76780a71aa34 (patch)
tree7b8643b5144db15c53536abf69dec2a49aa31bef /target/linux/generic/patches-2.6.38/670-phy_ip175c.patch
parent318102d24a60f6442052508c391aa984c5dbf97c (diff)
downloadupstream-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.tar.gz
upstream-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.tar.bz2
upstream-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.zip
[target/generic]: preliminary 2.6.38 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25057 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.38/670-phy_ip175c.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/670-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/670-phy_ip175c.patch b/target/linux/generic/patches-2.6.38/670-phy_ip175c.patch
new file mode 100644
index 0000000000..0af080bc9b
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -106,6 +106,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP17XX_PHY
++ tristate "Driver for IC+ IP17xx switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o