aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/420-gpiodev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
commitc700e57cc7b1ec4cd15dc1d5342bc9053308b8b8 (patch)
treefffe1ce8f0bbf431763fbb40f3388dc5e1d4ed8b /target/linux/generic/patches-2.6.38/420-gpiodev.patch
parent02bf1599a3b87a41686bf1cb78d62fe71040b192 (diff)
downloadupstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.tar.gz
upstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.tar.bz2
upstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.zip
preliminary 2.6.38 support
SVN-Revision: 25057
Diffstat (limited to 'target/linux/generic/patches-2.6.38/420-gpiodev.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/420-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/420-gpiodev.patch b/target/linux/generic/patches-2.6.38/420-gpiodev.patch
new file mode 100644
index 0000000000..6aa65c9256
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/420-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1047,6 +1047,14 @@ config NSC_GPIO
+ pc8736x_gpio drivers. If those drivers are built as
+ modules, this one will be too, named nsc_gpio
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -82,6 +82,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+