aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
commit3be9b7712746486e377d87113cf40673d2317858 (patch)
tree930d9739c436240cb27ee51e5ff186bf53996c0b /target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
parentdef45b136cf95d555d4e18bea7b5caa56155d0b7 (diff)
downloadupstream-3be9b7712746486e377d87113cf40673d2317858.tar.gz
upstream-3be9b7712746486e377d87113cf40673d2317858.tar.bz2
upstream-3be9b7712746486e377d87113cf40673d2317858.zip
kernel: remove all local symbols from kernel modules at link time to reduce their size
SVN-Revision: 26298
Diffstat (limited to 'target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
new file mode 100644
index 0000000000..86a3e2f1f8
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -361,7 +361,7 @@
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)