aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
commitc700e57cc7b1ec4cd15dc1d5342bc9053308b8b8 (patch)
treefffe1ce8f0bbf431763fbb40f3388dc5e1d4ed8b /target/linux/generic/patches-2.6.38/012-extra_optimization.patch
parent02bf1599a3b87a41686bf1cb78d62fe71040b192 (diff)
downloadupstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.tar.gz
upstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.tar.bz2
upstream-c700e57cc7b1ec4cd15dc1d5342bc9053308b8b8.zip
preliminary 2.6.38 support
SVN-Revision: 25057
Diffstat (limited to 'target/linux/generic/patches-2.6.38/012-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/012-extra_optimization.patch b/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
new file mode 100644
index 0000000000..4984fad29b
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -541,7 +541,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -596,6 +596,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+