aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:21 +0000
commitbb7cacb10f3e571e0955e1926c0e84ab3fec47e0 (patch)
tree9f52b71698a01a09923ca445e48566dcb47b2f54 /target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
parentc19a05ddc769a8b14837218fea04fe8b5c887eee (diff)
downloadupstream-bb7cacb10f3e571e0955e1926c0e84ab3fec47e0.tar.gz
upstream-bb7cacb10f3e571e0955e1926c0e84ab3fec47e0.tar.bz2
upstream-bb7cacb10f3e571e0955e1926c0e84ab3fec47e0.zip
kernel: reorganize 2.6.37 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26692 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch b/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
deleted file mode 100644
index fdfeb54335..0000000000
--- a/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -156,4 +156,29 @@ config MDIO_OCTEON
-
- If in doubt, say Y.
-
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GENERIC_GPIO
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366RB_PHY
-+ tristate "Driver for the Realtek RTL8366RB switch"
-+ select SWCONFIG
-+
-+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366 switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY || RTL8366RB_PHY
-+ depends on DEBUG_FS
-+ default n
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o