aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
commit76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0 (patch)
treee173de5498db08719c81621c36a6bbbdb0c67eb0 /target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
parent208df9da51b8ff30c79828d50c934ada4f580764 (diff)
downloadupstream-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.tar.gz
upstream-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.tar.bz2
upstream-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.zip
target/linux: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23828 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..60a9f38903
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -389,4 +389,8 @@ endif # LEDS_TRIGGERS
+
+ endif # LEDS_CLASS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -50,3 +50,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o