aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/620-phy_adm6996.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
commit93d46eff0251eed425d040eb57ab884881cc7bbf (patch)
treef0db464d80e07fbb18c9f99ac73f45aadf7e22a6 /target/linux/generic/patches-2.6.36/620-phy_adm6996.patch
parent324a2cedd382a542391a01b2092686b0befbbf6a (diff)
downloadupstream-93d46eff0251eed425d040eb57ab884881cc7bbf.tar.gz
upstream-93d46eff0251eed425d040eb57ab884881cc7bbf.tar.bz2
upstream-93d46eff0251eed425d040eb57ab884881cc7bbf.zip
linux/generic: add kernel 2.6.36 preliminary support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22832 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.36/620-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/620-phy_adm6996.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/620-phy_adm6996.patch b/target/linux/generic/patches-2.6.36/620-phy_adm6996.patch
new file mode 100644
index 0000000000..86bab7a1eb
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/620-phy_adm6996.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -93,6 +93,11 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o