aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-05 08:50:54 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-05 08:50:54 +0000
commit76f0b54cd5e718183374acb8bd4e0e00eb91ca17 (patch)
tree0c8716c5e67d2f8142dc9e18a5bac307c709c041 /target/linux/generic/patches-2.6.36/410-gpio_buttons.patch
parent3784ca2da7f11cd7f8301e52a475459331a8fc5a (diff)
downloadupstream-76f0b54cd5e718183374acb8bd4e0e00eb91ca17.tar.gz
upstream-76f0b54cd5e718183374acb8bd4e0e00eb91ca17.tar.bz2
upstream-76f0b54cd5e718183374acb8bd4e0e00eb91ca17.zip
linux/generic: refresh 2.6.36 kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23237 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.36/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/410-gpio_buttons.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/patches-2.6.36/410-gpio_buttons.patch b/target/linux/generic/patches-2.6.36/410-gpio_buttons.patch
index 0ca90237bc..b34d1175aa 100644
--- a/target/linux/generic/patches-2.6.36/410-gpio_buttons.patch
+++ b/target/linux/generic/patches-2.6.36/410-gpio_buttons.patch
@@ -1,8 +1,8 @@
--- a/drivers/input/misc/Kconfig
+++ b/drivers/input/misc/Kconfig
-@@ -390,4 +390,20 @@ config INPUT_PCAP
+@@ -438,4 +438,20 @@ config INPUT_ADXL34X_SPI
To compile this driver as a module, choose M here: the
- module will be called pcap_keys.
+ module will be called adxl34x-spi.
+config INPUT_GPIO_BUTTONS
+ tristate "Polled GPIO buttons interface"
@@ -23,7 +23,7 @@
endif
--- a/drivers/input/misc/Makefile
+++ b/drivers/input/misc/Makefile
-@@ -37,4 +37,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR) += winb
+@@ -41,4 +41,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR) += winb
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
obj-$(CONFIG_INPUT_YEALINK) += yealink.o