aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commita082943b09f4f707990ad0ac6326df8480507f02 (patch)
treede32e4def600e56134cd085a7447cb6620542078 /target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch
parent67fbcc7bd42cc07b1f3c6b5c9f2db37647178f25 (diff)
downloadupstream-a082943b09f4f707990ad0ac6326df8480507f02.tar.gz
upstream-a082943b09f4f707990ad0ac6326df8480507f02.tar.bz2
upstream-a082943b09f4f707990ad0ac6326df8480507f02.zip
rename target/linux/generic-2.6 to generic
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch b/target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..76413e9cef
--- /dev/null
+++ b/target/linux/generic/patches-2.6.35/970-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -836,3 +836,6 @@ config CRYPTO_ANSI_CPRNG
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #