aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-07-17 14:10:39 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-07-17 14:10:39 +0000
commit5272f096fb0541852734245658d3247cc1395d2f (patch)
tree8d1c382840f7148dc13b1f9ca30e753adb61a929 /target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch
parent3770e0e7facafd3c2f9d0a73b5e1b93c97affc97 (diff)
downloadupstream-5272f096fb0541852734245658d3247cc1395d2f.tar.gz
upstream-5272f096fb0541852734245658d3247cc1395d2f.tar.bz2
upstream-5272f096fb0541852734245658d3247cc1395d2f.zip
kernel: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22252 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch b/target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch
index 65f17b49eb..eda7a4e8fd 100644
--- a/target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch
+++ b/target/linux/generic/patches-2.6.35/921-gpio_spi_driver.patch
@@ -338,7 +338,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+MODULE_LICENSE("GPL v2");
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -133,6 +133,15 @@ config SPI_GPIO
+@@ -143,6 +143,15 @@ config SPI_GPIO
GPIO operations, you should be able to leverage that for better
speed with a custom version of this driver; see the source code.
@@ -356,9 +356,9 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
depends on ARCH_MXC
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_DESIGNWARE) += dw_spi.
- obj-$(CONFIG_SPI_DW_PCI) += dw_spi_pci.o
+@@ -23,6 +23,7 @@ obj-$(CONFIG_SPI_DW_PCI) += dw_spi_pci.
obj-$(CONFIG_SPI_DW_MMIO) += dw_spi_mmio.o
+ obj-$(CONFIG_SPI_EP93XX) += ep93xx_spi.o
obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
obj-$(CONFIG_SPI_IMX) += spi_imx.o