aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.35/650-swconfig.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commita082943b09f4f707990ad0ac6326df8480507f02 (patch)
treede32e4def600e56134cd085a7447cb6620542078 /target/linux/generic/patches-2.6.35/650-swconfig.patch
parent67fbcc7bd42cc07b1f3c6b5c9f2db37647178f25 (diff)
downloadupstream-a082943b09f4f707990ad0ac6326df8480507f02.tar.gz
upstream-a082943b09f4f707990ad0ac6326df8480507f02.tar.bz2
upstream-a082943b09f4f707990ad0ac6326df8480507f02.zip
rename target/linux/generic-2.6 to generic
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.35/650-swconfig.patch')
-rw-r--r--target/linux/generic/patches-2.6.35/650-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.35/650-swconfig.patch b/target/linux/generic/patches-2.6.35/650-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic/patches-2.6.35/650-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o